NOTE: click here if you get an empty page.
SSH-KEYSIGN(8) BSD System Manager's Manual SSH-KEYSIGN(8)
ssh-keysign - ssh helper program for hostbased authentication
ssh-keysign is used by ssh(1) to access the local host keys and generate
the digital signature required during hostbased authentication with SSH
protocol version 2.
ssh-keysign is disabled by default and can only be enabled in the global
client configuration file /etc/ssh/ssh_config by setting EnableSSHKeysign
ssh-keysign is not intended to be invoked by the user, but from ssh(1).
See ssh(1) and sshd(8) for more information about hostbased authentica-
Controls whether ssh-keysign is enabled.
These files contain the private parts of the host keys used to
generate the digital signature. They should be owned by root,
readable only by root, and not accessible to others. Since they
are readable only by root, ssh-keysign must be set-uid root if
hostbased authentication is used.
The reseeding of the OpenSSL random generator is usually done
from /dev/urandom. If the SSH_USE_STRONG_RNG environment vari-
able is set to value other than 0 the OpenSSL random generator is
reseeded from /dev/random. The number of bytes read is defined
by the SSH_USE_STRONG_RNG value. Minimum is 6 bytes. This set-
ting is not recommended on the computers without the hardware
random generator because insufficient entropy causes the connec-
tion to be blocked until enough entropy is available.
ssh(1), ssh-keygen(1), ssh_config(5), sshd(8)
ssh-keysign first appeared in OpenBSD 3.2.
Markus Friedl <email@example.com>
BSD May 24, 2002 BSD
© 1994 Man-cgi 1.15, Panagiotis Christias <firstname.lastname@example.org>